Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#28686 closed defect (bug) (duplicate)

/wp-admin/load-styles.php serious bug

Reported by: webbakery's profile webbakery Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Script Loader Keywords:
Focuses: administration Cc:

Description (last modified by SergeyBiryukov)

load-styles.php doesn't load on my fresh installation of wordpress on own centos 6.5 server. Causing due to a wrong path defined in this file's code.

On top of the file "load-styles.php", "WPINC" is defined but not used on line's 95-96. By typing "/wp-includes" in stead of user "WPINC", there's added an extra "/" when combining with "ABSPATH" (where a slash is added in php: dirname(dirname(__FILE__)) . '/').

Change History (3)

#1 @wonderboymusic
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14157.

Fixed in [28906].

#2 @SergeyBiryukov
10 years ago

  • Description modified (diff)

#3 @SergeyBiryukov
10 years ago

Actually, fixed in [28914] by reverting [28911]. wp-admin/load-styles.php calls wp_default_styles() without loading wp-includes/link-template.php, so includes_url() is unavailable there.

Thanks for the report!

Last edited 10 years ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.