WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#28696 closed defect (bug) (fixed)

Change to multisite's bootstrap causes undefined functions

Reported by: Ipstenu Owned by:
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description (last modified by ocean90)

I updated a theme and ended up with a WSoD, and also found that running commands (esp. on wp-cli) netted me this:

Fatal error: Call to undefined function ms_subdomain_constants() in /home/ipstenu/public_html/wp-includes/ms-settings.php on line 18

I traced it back to this changeset: [28910]

When I reverted the changes to /wp-includes/ms-settings.php then everything worked again.

If I only reverted the default constants, I got this:

Fatal error: Call to undefined function get_site_by_path() in /home/ipstenu/public_html/wp-includes/ms-settings.php on line 56

Apparently things aren't being loaded soon enough for Multisite?

Tested on latest SVN. No errors on 3.9.1

Change History (9)

#1 @jeremyfelt
6 years ago

I was wondering if this could happen.

I think this would only occur if ms-settings.php was being included outside of the normal wp-settings.php process. I'm not yet sure when that would happen, but I'll dig. Any plugins or themes or sunrises involved?

#2 @jeremyfelt
6 years ago

It looks like half of this is WP-CLI needing to be updated to match the new boot as of [28910] in wp-settings-cli.php.

#3 @ocean90
6 years ago

  • Description modified (diff)

So you have updated the theme through WP-CLI?

#4 @Ipstenu
6 years ago

jeremyfelt: No sunrise.

ocean90: No, I did not use wp-cli to update the theme. I used wp-cli when I tried to go in after the WSOD.

1) Update theme the normal way
2) See WSoD
3) Go to wp-cli to disable theme
4) Error

#5 @jeremyfelt
6 years ago

I went through a theme upgrade with 2 themes (Parallax and Semicolon) just now and was not able to reproduce the WSOD issue on the admin or front end. I don't have a sunrise or any plugins setup and this was with a freshly converted subdomain multisite installation.

#6 @Ipstenu
6 years ago

I'm confident the WSoD was a failed install now. Reinstalled the theme, no problems.

#7 @SergeyBiryukov
6 years ago

Sounds like wp-settings.php was not updated on that install.

Anything we need to do here?

#8 @Ipstenu
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I've pinged Shredder about WPCLI :) Though Daniel's here so he knows too now :D

I'll keep an eye on the oddities. I've force updated WP to svn trunk and it seems to be okay now.

#9 @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to 4.0
  • Resolution changed from invalid to fixed

Fixed in [28934].

Note: See TracTickets for help on using tickets.