WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#2872 closed defect (bug) (worksforme)

Error in SQL syntax

Reported by: kartlink Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: General Keywords:
Focuses: Cc:

Description

I am getting this on my front page:

WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '6 AND (post_type = 'post' AND (post_status = 'publish' OR post_status = 'private' at line 1]
SELECT DISTINCT blog_posts.* FROM blog_posts LEFT JOIN blog_post2cat ON (blog_posts.ID = blog_post2cat.post_id) WHERE 1=1 AND 0=1 6 AND (post_type = 'post' AND (post_status = 'publish' OR post_status = 'private')) ORDER BY post_date DESC LIMIT 0, 10

WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '6 AND (post_type = 'post' AND (post_status = 'publish' OR post_status = 'private' at line 1]
SELECT DISTINCT blog_posts.* FROM blog_posts LEFT JOIN blog_post2cat ON (blog_posts.ID = blog_post2cat.post_id) WHERE 1=1 6 AND (post_type = 'post' AND (post_status = 'publish' OR post_status = 'private')) ORDER BY post_date DESC LIMIT 0, 10

Archives and posts are working fine. I don't know what triggered this, it was working after the last post I made yesterday. Have already repaired the tables and it hasn't made any difference.

Change History (2)

comment:1 markjaquith8 years ago

Latest SVN version? All plugins disabled?

comment:2 Nazgul8 years ago

  • Priority changed from high to normal
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Unable to reproduce.

If you have any additional information, please feel free to re-open this ticket.

Note: See TracTickets for help on using tickets.