WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#28725 closed defect (bug) (duplicate)

wp_editor may not load utf-8 content

Reported by: tomas.k.7 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Formatting Keywords:
Focuses: Cc:

Description

requirements:
wp_options -> blog_charset = 'UTF-8'

brief problem description:
when you send string containing character \xA0 to wp_editor(), it loads without any content.

technical background:
caused by

$output = htmlspecialchars($output, ENT_NOQUOTES, get_option( 'blog_charset' ) );

in wp-includes/formatting.php at lines 2802 and 2821

one of possible examples how to simulate the the issue:

...
$content = html_entity_decode('A A');
wp_editor($content, ...);
...

result is dependent on php version used, some versions may work correctly...

Change History (3)

#2 @miqrogroove
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20368.

#3 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.