WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 4 years ago

#28731 closed defect (bug) (maybelater)

No way to go back to themes.php when in theme-install.php

Reported by: iseulde Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Themes Keywords: needs-patch ui-feedback ux-feedback
Focuses: ui, administration Cc:

Description

Actually there is one way, clicking the active themes link under appearance, but that doesn't make any sense.

I think it'd make most sense to move the entire "installed themes" page under a separate tab, instead of having a separate page for installing themes and adding new themes.

Change History (6)

#1 @SergeyBiryukov
6 years ago

This appears to be consistent with other screens.

The only way to go back from "Add New Post" to "Posts", from "Upload New Media" to "Media Library", from "Install Plugins" to "Plugins", from "Add New User" to "Users", etc. is via the admin menu.

#2 @iseulde
6 years ago

The problem is that there's no Add Themes/Add New menu item.

#3 @engelen
6 years ago

@SergeyBiryukov
I see part of the analogy here, but it doesn't fully apply. The "Add new themes" is quite the odd man out in the list of "Add new" pages in the admin panel. As it doesn't have its own menu item, the navigational part is quite unclear anyway.

Seeing as the "Add Themes" page is in some way a sub-page of the "Themes" page, I wouldn't consider a back button of some sort a bad idea.

#4 @studionashvegas
6 years ago

This carries the same functionality as the "Add Plugins" dialogs. There's no way to get back to the "Installed Plugins" page except from the sidebar admin... It's safe to say that the plugins and themes are similar enough to have them behave the same.

If we change one, changing the other would be a good idea (adding a link to go back to the Installed Plugins).

Then again, there's a case to leave it as-is since other parts of the site with similar behavior are doing the same thing.

#5 @chriscct7
5 years ago

  • Keywords ux-feedback added

#6 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

No traction in 2 years, and it applies to plugins as well, per comment:4.

Feel free to reopen with a patch if there's still interest.

Note: See TracTickets for help on using tickets.