WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28733 closed defect (bug) (duplicate)

Theme previewing fails because of mixed content errors (SSL)

Reported by: stephdau Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Themes Keywords:
Focuses: Cc:
PR Number:

Description

I'm getting mixed content errors while trying to preview not-yet-installed themes inside a WP install running under SSL.

This happens because we try to load the theme preview from its originator, such as http://wp-themes.com/zinnia

Looks like the previewing should be "proxied" via the local install instead.

Samples errors:

[blocked] The page at 'https://localhost/~epsi/wptrunk/wp-admin/theme-install.php?theme=zinnia'
was loaded over HTTPS, but ran insecure content from 'http://wp-themes.com/zinnia': this content
should also be loaded over HTTPS.

Attachments (2)

Screen Shot 2014-07-03 at 10.42.21.png (658.2 KB) - added by stephdau 5 years ago.
Screen Shot 2014-07-03 at 11.18.22.png (697.3 KB) - added by stephdau 5 years ago.

Download all attachments as: .zip

Change History (9)

#1 @stephdau
5 years ago

Actually, https://wp-themes.com/ is valid and working fine, so it'd probably just be a matter of moving to protocol-relative URLs (wp-themes.com/), if it is the only domain all themes are always previewed under.

#3 follow-up: @Otto42
5 years ago

Note that https://wp-themes.com/ is valid and working fine now. It was not yesterday. :)

We still need to go through and SSL all-the-things on that site, so using a protocol-relative URL is the correct way to go for core. That site will be made fully SSL capable, even if it is not quite there yet.

But yes, wp-themes.com is the official domain that theme previews will happen under for w.org.

#4 in reply to: ↑ 3 @stephdau
5 years ago

Replying to Otto42:

Note that https://wp-themes.com/ is valid and working fine now. It was not yesterday. :)

Heheh, nice timing. :)

We still need to go through and SSL all-the-things on that site, so using a protocol-relative URL is the correct way to go for core. That site will be made fully SSL capable, even if it is not quite there yet.

But yes, wp-themes.com is the official domain that theme previews will happen under for w.org.

Awesome, thanks Otto.

This ticket was mentioned in IRC in #wordpress-dev by helen. View the logs.


5 years ago

#6 @helen
5 years ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed

Closing as a dupe of #meta344 - feel free to reopen if something needs to change in core to accommodate.

#7 @helen
5 years ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.