WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28781 closed defect (bug) (duplicate)

redirect issue with post_id/postname or postname/post_id permalink structure

Reported by: calvin_ngan Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: General Keywords:
Focuses: Cc:

Description

Using www.example.com/%post_id%/%postname%/ as permalink structure, mMost canonical redirects work fine, except:

www.example.com/post_id/ brings you to the post but does not redirect to the canonical www.example.com/post_id/postname/

For example
http://www.geckoandfly.com/16402/smarter-effective-to-do-list-things/
http://www.geckoandfly.com/16402/

http://blog.miragestudio7.com/10-breathtaking-infinity-swimming-pools-around-world/5635/
http://blog.miragestudio7.com/10-breathtaking-infinity-swimming-pools-around-world/

and it is not an isolated issue, every wordpress installation with the same permalink configuration has the same problem.

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12456.

Note: See TracTickets for help on using tickets.