WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#28796 closed enhancement (duplicate)

Unable to change File visibility

Reported by: SupremeEmperor Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Media Keywords:
Focuses: Cc:

Description

When creating a Post or Page, there's a 'Visibility' option with 3 options: Public (anyone can view) Password-protected, and Private (only registered users can view the content).
These privacy settings are missing for Files, however, leaving no way to protect images from anonymous viewing. This ability should be included in WordPress. (Password-protection would be infeasible, but the Private option would be doable and needed.)

Change History (2)

#1 @ocean90
6 years ago

Related: #17255

#2 @wonderboymusic
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17255.

Note: See TracTickets for help on using tickets.