WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28815 closed defect (bug) (wontfix)

Browser beforeunload confirmation being fired when trashing post

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Editor Keywords: has-patch reporter-feedback
Focuses: administration Cc:

Description

Steps to reproduce:

  • Add a new post
  • Enter a title and some text in the content area
  • Click the 'Move to Trash' link next to the Publish button

Note that you'll be presented with an "Are you sure you want to leave this page?" confirmation.

Looks like this was introduced in 3.9.

Attachments (1)

28815.1.diff (507 bytes) - added by bordoni 6 years ago.

Download all attachments as: .zip

Change History (4)

#1 @bordoni
6 years ago

  • Keywords has-patch reporter-feedback added; needs-patch removed

So I've patched it to remove the beforeunload.edit-post when the button clicked has the class submitdelete.

@bordoni
6 years ago

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.


6 years ago

#3 @DrewAPicture
6 years ago

  • Milestone 4.0 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This seems like expected behavior in throwing an AYS. In other words, feature not a bug.

Note: See TracTickets for help on using tickets.