WordPress.org

Make WordPress Core

Opened 5 years ago

Last modified 5 months ago

#28845 new enhancement

Better error messages when uploading theme as plugin and vice versa

Reported by: tollmanz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: needs-patch
Focuses: administration Cc:
PR Number:

Description

When uploading a plugin package in the theme upload section, you will get an error message like:

Unpacking the package…

Installing the theme…

The package could not be installed. The theme is missing the style.css stylesheet.

Theme install failed.

You get a similar message when you try uploading a theme as a plugin.

Because a plugin or a theme package is detectable, the error message should be more helpful. It should point the user where to go to upload the package.

Ideally, we could just detect have the package installed anyone as the correct package type; however, for now, improved messaging could be really helpful.

Change History (1)

#1 @chriscct7
4 years ago

  • Keywords needs-patch added
Note: See TracTickets for help on using tickets.