WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28871 closed defect (bug) (fixed)

Media: List View and Grid View links do not work with screen readers

Reported by: davidakennedy Owned by: ocean90
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords:
Focuses: accessibility Cc:

Description

What happened: When I visit /wp-admin/upload.php and navigate to the List View or Grid View links, I do not hear any audible feedback from the screen reader, only "Link"

What I expected: I would expect to hear something like: "Link: List View" and "Link: Grid View"

Steps to reproduce: 1. Visit /wp-admin/upload.php 2. Navigate to the List View or Grid View links with a screen reader

Thoughts: This happens because:

  • The links have no link text.
  • There are currently blank.gif with alt text, however, these have a style of display: none; so a screen reader never hears anything because with that style, it's hidden from everything.

Solutions: Use the screen-reader-text class on a span inside the links to hide the text but still make it available to screen readers. The blank.gifs may need to be removed. Not sure if they're used elsewhere.

Attachments (1)

28871.diff (2.8 KB) - added by davidakennedy 5 years ago.
28871 Patch

Download all attachments as: .zip

Change History (4)

@davidakennedy
5 years ago

28871 Patch

#1 @davidakennedy
5 years ago

My patch is a first pass. I may not have gotten everything needed.

#2 @ocean90
5 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 29133:

Lists View Switcher: Replace blank image with screen reader text.

props davidakennedy.
fixes #28871.

#3 @ocean90
5 years ago

  • Milestone changed from Awaiting Review to 4.0

Thanks David! :)

Note: See TracTickets for help on using tickets.