WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28879 closed defect (bug) (fixed)

Admin panel taxonomy terms listing results in a fatal error

Reported by: magadanski_uchen Owned by: wonderboymusic
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: Taxonomy Keywords:
Focuses: administration Cc:
PR Number:

Description

I installed WordPress 4.0 and going to a taxonomy terms (such as categories at /wp-admin/edit-tags.php?taxonomy=category) I get the following fatal error:

Access level to WP_Terms_List_Table::get_columns() must be public (as in class WP_List_Table) in \wp-admin\includes\class-wp-terms-list-table.php on line 456

Change History (7)

#1 @danielbachhuber
5 years ago

I can't reproduce in my local checkout, and WP_Terms_List_Table::get_columns() is public in my local install.

To confirm, this is a stock install with no plugins and Twenty Fourteen active? Can you look into why the method might be something other than public?

#2 @danielbachhuber
5 years ago

  • Keywords reporter-feedback added

#3 @ocean90
5 years ago

Related: #28843

#4 @wonderboymusic
5 years ago

I am fixing these now - tons of mismatches in List Table subclasses

#5 @SergeyBiryukov
5 years ago

  • Component changed from Administration to Taxonomy

Could not reproduce neither on PHP 5.2.4 (minimal required version) nor on 5.2.17.

WP_Terms_List_Table::get_columns() is public, see [29118]. Make sure you have that file updated.

#6 @wonderboymusic
5 years ago

  • Owner set to wonderboymusic
  • Resolution set to fixed
  • Status changed from new to closed

In 29137:

Fix mismatches in access modifiers for WP_List_Table + subclasses.

Fixes #28843, #28879.

#7 @SergeyBiryukov
5 years ago

  • Keywords reporter-feedback removed
  • Milestone changed from Awaiting Review to 4.0
Note: See TracTickets for help on using tickets.