WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 9 months ago

#28896 closed defect (bug) (worksforme)

Media Grid: image description HTML edit buttons are missing

Reported by: designsimply Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords:
Focuses: Cc:

Description

In the past, there were some helper buttons for formatting HTML (i.e. adding links) to image descriptions:


Those appear to be gone in 4.0. Were they removed on purpose? May I ask why?

I’m asking because I can see that users are already missing easy access to those editor buttons. Here is an example user help request asking why the buttons were removed:
http://premium-themes.forums.wordpress.com/topic/add-links-to-gallery-images?replies=14

Here is a screencast showing how the HTML edit buttons for image descriptions has changed from 3.8.3 to 3.9.1 to 4.0-beta1 r284949 tested with Chrome 35.0.1916.153 on Mac OS X 10.9.4:

https://cloudup.com/cj27Dc3PGX6 (Length: 3:20)

Would you consider adding the image description HTML editing buttons back?

Attachments (1)

Screen Shot 2014-07-14 at Mon Jul 14 1.20.42 PM.png (597.3 KB) - added by designsimply 10 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 @ocean9010 months ago

There was a report on the support forum too: https://wordpress.org/support/topic/missing-tinymce-at-mediathek-description

Seems like a cache issue, because Monika has reported that they were back after a fresh install.

comment:2 @helen10 months ago

We still need to link to the full attachment edit screen from the library somewhere. The modal is not a replacement for that.

comment:3 @Ipstenu10 months ago

They're not there on the in-line editor either (when I edit a post and click on an image to edit).

comment:4 @helen9 months ago

The link to the full edit attachment screen is back in the modal now. There were not formatting buttons in the modals before, and it is rather late in the cycle to be doing such an enhancement for 4.0. What needs to be done here, realistically?

comment:5 @Ipstenu9 months ago

I think this is fine. If we want to look into putting the formatting buttons in the modal, that should be another ticket. Having them be two-clicks away from media library is annoying, but at the same time, you can actually select the text and format within the post.

Example: Put an image in your post with a caption. Highlight the caption text and click bold. Boom. Bold!

comment:6 @helen9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.