WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#28926 closed defect (bug) (duplicate)

Custom header don't output URL for image if it doesn't exists

Reported by: michalzuber Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Customize Keywords: has-patch dev-feedback
Focuses: template Cc:

Description

I was working on a patch for #28904 and tried removing the custom header file. WP outputs the URL when the file doesn't exists http://i.imgur.com/b3LKV9n.png and http://i.imgur.com/S4NVbxc.png
It also triggers a PHP error File does not exist: /Users/mike/Sites/wordpress-svn/src/wp-content/uploads/2014/07/cropped-macbook43.jpg, referer: http://localhost/wordpress-svn/src/

Attachments (1)

28926.patch (1.3 KB) - added by michalzuber 5 years ago.

Download all attachments as: .zip

Change History (3)

@michalzuber
5 years ago

#1 @michalzuber
5 years ago

  • Keywords has-patch dev-feedback added

#2 @SergeyBiryukov
5 years ago

  • Component changed from Themes to Customize
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17800. To clarify, "File does not exist" is an Apache error, not PHP.

Note: See TracTickets for help on using tickets.