WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28955 closed defect (bug) (invalid)

TinyMCE Add Media drag and drop

Reported by: zishanj Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Editor Keywords:
Focuses: Cc:

Description

I am trying to use TinyMCE editor in custom page in wp admin "Settings" area. I am able to load it using wp_editor() with drag_drop_upload and media_buttons enabled. It loaded well. But the problem is when I click the "Add Media" button, it shows a popup screen but I can't drag and drop files to upload in it. The drag and drop upload feature in Media Library seems to be disabled. This feature works well in PAGES and POSTS area. Is it a bug or there is a workaround to this?

Change History (2)

#1 @zishanj
6 years ago

Sorry for reporting this. I figured out that it was a conflict of lodash library (extended library for underscore with enhanced performance) with underscore library which WP loads by default to use with Media Library. I suggest its better that WP also use lodash library instead of underscore in future version.

#2 @helen
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.