WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#28962 closed defect (bug) (fixed)

Impossible to close the interim login modal

Reported by: johnbillion Owned by: chriscct7
Milestone: 4.4 Priority: normal
Severity: normal Version: 2.9
Component: Login and Registration Keywords: has-patch needs-testing
Focuses: administration Cc:

Description

Steps to reproduce:

  1. Open a post for editing
  2. Clear your cookies or log out of the site in another window
  3. When autosave or heartbeat kicks in, you'll be presented with the "Session expired" modal window
  4. Attempt to close the window using the X in the top right corner

Note that the modal closes but immediately re-opens. We should allow this window to be closed in case the user needs to access any of the content on the screen.

Attachments (1)

28962.diff (482 bytes) - added by nofearinc 3 years ago.
disable heartbeat-tick.wp-auth-check

Download all attachments as: .zip

Change History (4)

@nofearinc
3 years ago

disable heartbeat-tick.wp-auth-check

#1 @nofearinc
3 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

Originally when hide() is called, only the beforeunload.wp-auth-check callback is disabled, but not heartbeat-tick.wp-auth-check. The latter is checking for the wp-auth-check value in the callback which can't be changed since the user is still logged out, we just don't want to display the popup constantly.

If we deactivate the heartbeat-tick.wp-auth-check event handler the popup verification will be disabled as well until the next request is processed - and IMO other AJAX requests should behave properly and prevent non-authorized activities.

#2 @chriscct7
2 years ago

  • Milestone changed from Awaiting Review to 4.4
  • Owner set to chriscct7
  • Status changed from new to reviewing

#3 @wonderboymusic
2 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 35568:

Administration: when hiding the login modal and unbind the auth check, also unbind the heartbeat auth check.

Props nofearinc.
Fixes #28962.

Note: See TracTickets for help on using tickets.