WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28969 closed defect (bug) (duplicate)

Media Grid Modal, close button always focused

Reported by: michalzuber Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords: has-patch dev-feedback
Focuses: ui, javascript Cc:
PR Number:

Description

The close button of the modal is always focused.
Clicking next or previous arrows the focus always "jumps" to the close.
https://youtu.be/g4IlcensaIQ

Attachments (1)

28969.diff (474 bytes) - added by adamsilverstein 5 years ago.
prevent close from always gaining focus

Download all attachments as: .zip

Change History (4)

@adamsilverstein
5 years ago

prevent close from always gaining focus

#1 @adamsilverstein
5 years ago

  • Keywords has-patch dev-feedback added

28969.diff use JS to blur focus off close button after opening modal. Tried several approaches, still unclear why close is getting focus, this does prevent it.

#2 follow-up: @helen
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23560.

Purposeful, already noted for further refinement on the original ticket.

#3 in reply to: ↑ 2 @adamsilverstein
5 years ago

Thanks, missed that!

Replying to helen:

Duplicate of #23560.

Purposeful, already noted for further refinement on the original ticket.

Note: See TracTickets for help on using tickets.