Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#28981 closed feature request (duplicate)

Nicer HTML

Reported by: jmlapam's profile jmlapam Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Formatting Keywords:
Focuses: Cc:

Description

Hi, the visual editor is great and I've checked the latest beta release. This small change that makes the tinymce buttons stick to the top when scrolling is awesome !

Speaking about visual editor I was wondering if one day we could change all the span (with style="" within) to be more HTML-friendly so style would be added as CSS classes and then developer could style them easily in their CSS.

Moreover there are hidden option I can display in editor with simple filters such as mce_buttons, _2, _3 and _4 etc. But some of them can harm the design (fontselect, fontsizeselect). Maybe it could be removed?

It would not regard existing content because you know they have style tags. But I really think it would be nicer. What do you think about it?

Change History (1)

#1 @nacin
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27159.

Note: See TracTickets for help on using tickets.