WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#28998 closed enhancement (duplicate)

Media Grid: user feedback during content load

Reported by: Clorith Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords: close
Focuses: ui, javascript Cc:
PR Number:

Description

When scrolling the media grid, there's no feedback to the end user that more content is loading beyond the spinner in the toolbar.

I found one oddity where infinite scroll is triggered, and we check if we are near the end of the page, then show the spinner in the toolbar, this is redundant as the toolbar will in most situations not even be visible at this point.

I think a spinner taking up the space of a grid element while loading should be introduced to the list and shown whenever we are loading more content (keep the spinner size, I'm just referencing the DOM area it should occupy at the time).

Change History (6)

This ticket was mentioned in IRC in #wordpress-dev by Clorith. View the logs.


5 years ago

#2 @michalzuber
5 years ago

Tried with 400 images:

  1. Had no infinite scroll
  2. Only 79 items showed up in Media Grid instead 401 items as in List View

https://youtu.be/3f2ckjflFM8

I created images with the following script and then just added them. Selected them all and multiple upload took approx. 2minutes to finish

#!/bin/bash

for (( i = 0; i < 400; i++ )); do
	cp wordpress-logo-square.png wordpress-$i.png
done

UPDATE: Tried also in FF 31. Both Chrome and FF issues admin-ajax.php request, during 2 minutes Chrome made over 400 requests http://i.imgur.com/xOEI8dM.png

Last edited 5 years ago by michalzuber (previous) (diff)

#3 @SergeyBiryukov
5 years ago

  • Milestone changed from Awaiting Review to 4.0

#4 @dolorespente
5 years ago

Last edited 5 years ago by dolorespente (previous) (diff)

#5 @ocean90
5 years ago

  • Keywords close added
  • Summary changed from Media grid user feedback during content load to Media Grid: user feedback during content load

Duplicate of #28927?

#6 @helen
5 years ago

  • Milestone 4.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28927.

Note: See TracTickets for help on using tickets.