WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29016 closed defect (bug) (duplicate)

Shared taxonomy for custom post types reports wrong post count

Reported by: totland Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Taxonomy Keywords:
Focuses: administration Cc:
PR Number:

Description

I have a custom post type called "event", and I have enabled the default "category" taxonomy for that post type.

When going to wp-admin/edit-tags.php?taxonomy=category&post_type=event you will see the post count for each category to the left, listed under the column heading "Events". This count also includes regular posts (the default post type "post"). Likewise, when going to wp-admin/edit-tags.php?taxonomy=category the count for events are included. Very misguiding.

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14076, #14084, and #20708.

Note: See TracTickets for help on using tickets.