WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29018 closed defect (bug) (duplicate)

Plugin names should be included within links in Install Plugins

Reported by: GrahamArmfield Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Plugins Keywords:
Focuses: accessibility Cc:
PR Number:

Description

In the new Install Plugins screen there are links that carry the text 'Update Now' or 'Install Now'. There are also links that carry text 'More Details'.

None of these links contain the name of the plugins. So screen reader users using the list links functionality are getting no context to let them know which plugin is being referenced by the links.

The plugin name needs to be included in the links.

There is an aria-labelledby attribute in the links that refers to a non-existant element. Obviously someone has attempted to get some context for the links from this.

Unfortunately, the behaviour of aria-labelledby and aria-label when used on links is to override the link text. So if the current approach did work, the two links for each plugin would actually be identical for screen reader users, when obviously they are not.

In my view, and to cater for internationalisation I suggest this approach:

<a href="xxx" aria-label="Install plugin name now">Install now</a>

and the same approach for the More details link.

Sighted users won't see any difference, but screen reader users will hear the full link with context.

Attachments (1)

29018.patch (1.8 KB) - added by nvwd 5 years ago.
changed aria-labelledby to aria-label and added more descriptive text to be used by screen readers

Download all attachments as: .zip

Change History (6)

#1 @samuelsidler
5 years ago

  • Milestone changed from Awaiting Review to 4.0

@nvwd
5 years ago

changed aria-labelledby to aria-label and added more descriptive text to be used by screen readers

#2 @nvwd
5 years ago

  • Keywords has-patch added

Text added to aria-label attribute

  • Install {plugin title} now
  • Update {plugin title} now
  • More details about {plugin title}

#3 @ocean90
5 years ago

  • Keywords needs-patch added; has-patch removed

29018.patch doesn't work for i18n. Needs sprintf() if we want to go this way.


There is an aria-labelledby attribute in the links that refers to a non-existant element.

The attribute was added in [29201], see #28853. Maybe we should re-open the ticket?

#4 @nvwd
5 years ago

I will make the changes to the patch using sprintf().
This does seem to be part of #28853. I'll wait to attach the updated patch until a decision is reached about re-opening the original ticket.

#5 @ocean90
5 years ago

  • Keywords needs-patch removed
  • Milestone 4.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28853.

Note: See TracTickets for help on using tickets.