WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29039 closed defect (bug) (duplicate)

Permalink structure breaks in multisite installation

Reported by: geopal Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Permalinks Keywords:
Focuses: Cc:
PR Number:

Description

I have locally set up a multisite network with 2 sites enebled.

In the main (first) site, with path "/" and Home: "http://localhost/", I change in the settings page the Permalink Structure to be /%year%/%monthnum%/%postname%/ instead of /blog/%year%/%monthnum%/%postname%/

In the second site, with path "/en/" and Home: "http://localhost/en/", I also change in the settings page the Permalink Structure to be /%year%/%monthnum%/%postname%/ instead of /blog/%year%/%monthnum%/%postname%/

The problem begins when I visit the first sites' Permalink Settings. (See https://i.imgur.com/UCdHAP2.jpg)

The permalink structure says http://localhost/blog/2014/07/sample-post/ (with "/blog/" still in place) but when you visit the site the permalinks are normally working without "blog"

The total disaster comes when you try to enter custom structures for your category and tag URLs (Optional settings of Permalink Settings page). Then the total chaos occurs... Fortunately if you remake all the settings from the beginning with a specific order (which I am not quite sure what it is), all works fine again.

Thanks for your times, sorry for my English, hope the solution to be something simple.

Have a nice summer.

George P.
Athens, Greece

Attachments (1)

Permalink_Settings_Site_One.jpg (122.0 KB) - added by geopal 5 years ago.

Download all attachments as: .zip

Change History (2)

#1 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12002.

That you can remove the /blog prefix in Network Admin in site settings is just a hack. If you have removed the /blog prefix this way you shouldn't visit the permalinks settings of the specific site anymore.

Note: See TracTickets for help on using tickets.