WordPress.org

Make WordPress Core

Opened 7 years ago

Last modified 2 years ago

#29040 reopened defect (bug)

Customizer: Header Image not Updating when using static front page — at Version 1

Reported by: zhalsey Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version: 3.9
Component: Customize Keywords: needs-patch
Focuses: javascript Cc:

Description (last modified by ocean90)

Using WordPress 4.0 Beta 2. Steps to reproduce:
only happens if theme has default header image
(with twenty fourteen)

  • Open Customizer
  • Open Header image section
  • Click on previously uploaded, theme default, or new uploaded image
  • current header updates in customizer controls and preview
  • changing header image activates the save and publish button, but after pressing it and closing customizer the header image is not changed
  • when returning to the customizer the newly uploaded image is not present, however it does appear in the media library
  • after switching themes and the switching back all images do show up

(in another theme which has several default images and no header text)

  • Open Customizer
  • Open Header image section
  • Click on previously uploaded, theme default, or new uploaded image
  • current header updates in customizer controls
  • customizer preview does not update image, even after triggering a preview refresh with another control
  • changing header image activates the save and publish button, but after pressing it and closing customizer the header image is not changed

Tried on Google Chrome and Safari on both Windows and Mac

Is not always reproducible with every theme, inconsistent results.

Change History (1)

#1 @ocean90
7 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.