WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#29080 closed defect (bug) (fixed)

Media Trash is broken in WordPress 4.0-beta2-20140730

Reported by: dglingren Owned by: wonderboymusic
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords: has-patch
Focuses: Cc:

Description

The "Media Trash" feature no longer works because of a change in /wp-includes/post.php, function wp_insert_post.

At line 3149-3151 $post_status "trash" is lost because of new attachment-specific code that forces it back to "inherit".

Adding 'trash' to the list of acceptable status values corrects the problem.

Attachments (1)

29080.patch (554 bytes) - added by SergeyBiryukov 7 years ago.

Download all attachments as: .zip

Change History (4)

#1 @SergeyBiryukov
7 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 4.0

Related: [28788] for #21963.

#2 @wonderboymusic
7 years ago

  • Owner set to wonderboymusic
  • Resolution set to fixed
  • Status changed from new to closed

In 29337:

Unbreak Media Trash after [28788].

Props SergeyBiryukov.
Fixes #29080.

#3 @dglingren
7 years ago

I just updated to 4.0-beta2-20140805 and I can confirm that the patch has resolved the issue. Thanks for the quick and effective action!

Note: See TracTickets for help on using tickets.