WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#29103 closed defect (bug) (duplicate)

PHP notice in `list_plugin_updates()` if the Plugins API call fails

Reported by: johnbillion Owned by:
Milestone: Priority: low
Severity: minor Version: 2.9
Component: Upgrade/Install Keywords: has-patch
Focuses: Cc:

Description

Inside list_plugin_updates() a plugins_api() request is performed for each plugin (related: #20002). If the API request returns a WP_Error then we get a notice in the Plugins section of the Updates screen due to an undefined property.

Attachments (1)

29103.patch (1.6 KB) - added by johnbillion 7 years ago.

Download all attachments as: .zip

Change History (4)

@johnbillion
7 years ago

#1 @johnbillion
7 years ago

  • Keywords has-patch added; needs-patch removed

#2 @dd32
6 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

I can't duplicate this.

isset( $var->prop[ $a ][ $b ] ) suppresses all notices.
isset( $var->prop[ $other_var->not_a_prop ] ) will issue a Notice for $other_var->not_a_prop.

#3 @SergeyBiryukov
6 years ago

  • Resolution changed from invalid to duplicate

Duplicate of #29583.

Note: See TracTickets for help on using tickets.