WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29113 closed defect (bug) (duplicate)

Featured Image metabox available for contributors

Reported by: jkudish Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: has-patch
Focuses: ui, administration Cc:

Description

The featured image metabox (postimagediv) is available for contributors even though they cannot retrieve existing attachments nor upload new files. This leads to a confusing user experience.

I propose that we hide the featured image for users who cannot upload files.

Attachments (3)

29113.diff (685 bytes) - added by jkudish 5 years ago.
Screen Shot 2014-08-04 at 5.43.03 PM.png (108.3 KB) - added by jkudish 5 years ago.
Screen Shot 2014-08-04 at 5.42.56 PM.png (69.2 KB) - added by jkudish 5 years ago.

Download all attachments as: .zip

Change History (5)

@jkudish
5 years ago

#1 @SergeyBiryukov
5 years ago

  • Component changed from Administration to Media
  • Keywords dev-feedback needs-testing removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28327.

#2 @jkudish
5 years ago

Thanks -- not sure how I missed the duplicate despite the different search queries I tried.

Note: See TracTickets for help on using tickets.