WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#29114 closed defect (bug) (fixed)

wp-view is not visible with nonexistant media.

Reported by: programmin Owned by: azaozz
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords: has-patch
Focuses: ui, javascript Cc:

Description

Using the WP 4.0 beta (4.0-beta2-20140803), and Twenty Fourteen theme, I was seeing some weird behavior:

Go to a page that has the following in "text" mode:

<div>
Hello!
<div>
[playlist ids="45,30,24,22,20,18"]
</div>
</div>

Switch to Visual mode, and notice that the view isn't shown. (In this case, 45 and others were non-existent posts.) It only shows a big white space with no border.

(Tested on Chromium 34, Ubuntu 14.04)

Attachments (4)

39.png (16.6 KB) - added by ocean90 7 years ago.
trunk.png (20.4 KB) - added by ocean90 7 years ago.
29114.patch (739 bytes) - added by iseulde 7 years ago.
29114.2.patch (2.1 KB) - added by iseulde 7 years ago.

Download all attachments as: .zip

Change History (14)

#1 @tellyworth
7 years ago

  • Keywords needs-patch added

Confirmed in trunk, not an issue in 3.9.

@ocean90
7 years ago

@ocean90
7 years ago

#2 @ocean90
7 years ago

  • Milestone changed from Awaiting Review to 4.0

@iseulde
7 years ago

#3 @iseulde
7 years ago

  • Keywords has-patch added; needs-patch removed

#4 @azaozz
7 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 29546:

TinyMCE wpView: show an error when no items are found while parsing a audio/video/playlist shortcode. Props avryl, fixes #29114.

#5 @programmin
7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still happening in latest wp4.0 nightly-beta.

#6 @iseulde
7 years ago

Works for me, doing the steps above.

Last edited 7 years ago by iseulde (previous) (diff)

@iseulde
7 years ago

#7 @iseulde
7 years ago

It still keeps "loading" when you switch to text mode and back. The problem is that we're not caching error messages, only the parsed text. Patch above. Needs testing.

#8 @azaozz
7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 29577:

TinyMCE wpView: fix showing errors for non-embeddable URLs, no-ssl or no items. Props avryl, fixes #29114, see #29268.

#9 follow-up: @programmin
7 years ago

Sorry, looks like something is wrong with WP Beta Plugin and it's not grabbing what is the latest on SVN.

With the latest code from SVN this looks ok.

#10 in reply to: ↑ 9 @azaozz
7 years ago

Replying to programmin:

Thanks for confirming :)

Note: See TracTickets for help on using tickets.