WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29129 closed defect (bug) (worksforme)

TinyMCE adds empty headline after caption

Reported by: firebird75 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: TinyMCE Keywords: 2nd-opinion
Focuses: Cc:
PR Number:

Description (last modified by SergeyBiryukov)

How to reproduce this issue :

  1. Add a title tag with <h2></h2> for instance, <h2>My Title</h2> in text mode.
  2. Switch to visual mode and add a centered picture with a caption
  3. Put the cursor at the beginning of the heading H2 line and press enter to add a blank line
  4. Switch to text mode, the code will look like this :
    <h2></h2>
    <h2>My Title</h2>
    

TinyMCE has added a blank <h2></h2>

Change History (5)

#1 @SergeyBiryukov
5 years ago

  • Description modified (diff)
  • Summary changed from Tinymce adds empty headline after caption to TinyMCE adds empty headline after caption

#2 @azaozz
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This is browser dependent: happens only in IE. This is the way IE works in contentEditable mode. The same behavior is in MS Word.

#3 @firebird75
5 years ago

  • Keywords 2nd-opinion added
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I believe I have also seen this problem with other browsers as I am not using IE for WordPress posts edition...

#4 @azaozz
5 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Can't reproduce that in Chrome or FF on Win7. In either case it is a behavior that can be normalized in TinyMCE. There is an option to enable it in all browsers that is not used by default in WordPress.

Going to re-close this as worksforme. If you want it enabled in all browsers, you'll need a small plugin to add that setting to the TinyMCE init. If you want it disabled in all browsers, the only way I see is to open an enhancement request on the TinyMCE website (not sire if it's possible to disable this in IE).

#5 @firebird75
5 years ago

I am using FF 31.0.

I have made some additional test. Designmode is "off" (checked in Firebug). And still the problem shows up.

I understand that this issue isn't really critical but having some empty <h2></h2> can seem kind of spammy...

Note: See TracTickets for help on using tickets.