WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#29140 closed defect (bug) (invalid)

Bug in WordPress 4.0 beta 3 with Google Maps plugin

Reported by: sonusinghal Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Plugins Keywords:
Focuses: Cc:

Description

I tried to install google maps plugin on a totally fresh install. I got a fatal error. http://i.imgur.com/7Tysk4g.png

Attachments (1)

Plugin Install ‹ Unicorn Infotech — WordPress 2014-08-07 17-45-02.png (42.3 KB) - added by sonusinghal 7 years ago.

Download all attachments as: .zip

Change History (5)

#1 @SergeyBiryukov
7 years ago

  • Summary changed from Bug in Wordpress 4.0 beta 3 with google maps plugin to Bug in WordPress 4.0 beta 3 with Google Maps plugin
Fatal error: Maximum execution time of 120 seconds exceeded in wp-includes/class-http.php on line 1502

The error comes from WP_Http_Curl::stream_body(). This sounds like a slow connection or a network glitch.

#2 @sonusinghal
7 years ago

After a few experiments, I can confirm That it is indeed due to a slow network.
As this is on Localhost, I can't increase the network speed, so can I somehow increase the 120 second limit ?

#3 @michalzuber
7 years ago

On line /wp-includes/class-http.php#L80 is a apply_filters() you can use.

Last edited 7 years ago by michalzuber (previous) (diff)

#4 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

apply_filters() wouldn't help here, you need to increase max_execution_time and max_input_time values in your php.ini file, then restart the server.

Please try the support forums if you need more specific instructions: https://wordpress.org/support/.

Note: See TracTickets for help on using tickets.