WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#29142 closed defect (bug) (duplicate)

wptexturize inconsistent with em dashes (sometimes returns -- as a single en dash)

Reported by: andrealeebishop Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Formatting Keywords:
Focuses: Cc:

Description

http://codex.wordpress.org/Function_Reference/wptexturize

When I add this content to the Text tab or Visual tab of the post, not all of the double dashes are returned as an em dash.

Examples:
http://andrealeebishop.wpsandbox.me/?p=49 (content https://cloudup.com/cUfB8EYZVWe )
http://andrealeebishop.wpsandbox.me/?p=58 (content https://cloudup.com/cZFVkdUY7mM )

It is repeatable, but difficult to narrow down for steps to reproduce. nbsp's show up around the single dash when Inspect Element is used.

Change History (4)

#1 @miqrogroove
6 years ago

I can see a pattern to the output for any \xC2\xA0-- but I can't get my server to do the same.

I see you have PHP 5.5.14. Could you tell us which server operating system and any other pertinent details?

#2 @miqrogroove
6 years ago

Also note this is quite old and is not the trunk version. I can probably point you to the problem now.

<meta·name="generator"·content="WordPress·4.0-alpha-20140608"·/>(LF)

#3 @miqrogroove
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23185.

OP results not based on trunk version. Bug was a duplicate of a fixed issue and was not a regression from 3.9.

#4 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.