Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#29152 closed defect (bug) (fixed)

Insert New Media: Tabbing between fields sends you back to the image URL

Reported by: ipstenu's profile Ipstenu Owned by: ocean90's profile ocean90
Milestone: 4.0 Priority: high
Severity: normal Version: 4.0
Component: Media Keywords: has-patch
Focuses: accessibility, javascript, administration Cc:

Description

Steps to Reproduce:

1) In a post (new or old) insert a new image.
2) Use TAB to go to the TITLE and enter content
3) Use TAB again to go to CAPTION

What should happen is you're not in the CAPTION field. What actually happens is you're sent back to URL

This only happens on the Insert New Media modal, and is fine on the in-post editor in Visual Mode.

Attachments (2)

29152.patch (443 bytes) - added by iseulde 10 years ago.
29152.2.patch (585 bytes) - added by adamsilverstein 10 years ago.
add inline docs

Download all attachments as: .zip

Change History (9)

#1 @Ipstenu
10 years ago

What should happen is you're not in the CAPTION field.

Typo. What should happen is you ARE in the caption field. You're not. You're back up in URL.

This ticket was mentioned in IRC in #wordpress-dev by celloexpressions. View the logs.


10 years ago

#3 @celloexpressions
10 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.0

I can't reproduce, but Ipstenu can. Most likely a 4.0 regression from media-modal-keyboard improvements.

Related: #23560.

#4 @ocean90
10 years ago

  • Focuses accessibility javascript administration added
  • Priority changed from normal to high

I can reproduce this in Chrome 36 on OSX and it's a regression which is really annoying.

@iseulde
10 years ago

#5 @iseulde
10 years ago

  • Keywords has-patch added; needs-patch removed

Here's a fix. I have the feeling the problem lies somewhere else though. Why are we trying to select the attachment after saving attachment details? Why are we selecting an already selected attachment?

This ticket was mentioned in IRC in #wordpress-dev by ocean90. View the logs.


10 years ago

@adamsilverstein
10 years ago

add inline docs

#7 @ocean90
10 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 29553:

Insert Media: Don't select a model if it's already selected.

props avryl, adamsilverstein.
fixes #29152.

Note: See TracTickets for help on using tickets.