WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#29227 closed defect (bug) (wontfix)

Visual editor bug from turning to floating to simple TinyMCE in 4.0

Reported by: hardeepasrani Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords: close
Focuses: Cc:

Description

Looks like this is my 5th or 6th issue with the floating editor, so you can guess that I'm not in good terms with this editor.

Well, it's a working progress :)

Here's another bug (3rd this hour) that I found in the new floating TinyMCE editor.

When in the floating editor mode, try to type or paste anything to the visual editor without any spaces or line breaks, such as:

asasdalksjdhalsdhaksdasjd..... big enough that a scroll bar appear on the bottom of your visual editor.

Now turn off the floating editor and the simple editor will look something like the attached image.

The bottom scroll bar always appears on the very bottom of the floating editor, which is the same issue with the simple editor. It should also be fixed to the bottom of the editor.

Attachments (1)

editor scroll.png (15.7 KB) - added by hardeepasrani 7 years ago.

Download all attachments as: .zip

Change History (14)

#1 @johnbillion
7 years ago

  • Keywords reporter-feedback added

Thanks for your reports hardeepasrani.

I can see that you're on Windows 7 - which browser are you using please? And which theme are you using? I'm unable to reproduce the issue, both with and without my active theme's editor styles enabled.

#2 @hardeepasrani
7 years ago

I was using Firefox and it's worth noting that I was on a small screen notepad. It'll try on some other computers later tonight and will send you a video of it.

#3 @hardeepasrani
7 years ago

Here's a video of what I'm talking about: https://dl.dropboxusercontent.com/u/101184013/Video.wmv

Please reply if you got it :)

#4 @hardeepasrani
7 years ago

  • Keywords needs-patch added; reporter-feedback removed

I just removed the reporter-feedback tag and you can also take a look at the issue in this video: https://dl.dropboxusercontent.com/u/101184013/Video.wmv

Hope you are able to view this video :)

#5 @programmin
7 years ago

The screenshot seems to be showing that the min-height is not high enough in the default WP configuration? I remember there was a really annoying bug in earlier MCE3 that prevented making the editor smaller than some specific height. If this is changed back to the old behavior globally this could break other uses of TinyMCE.

#6 @hardeepasrani
7 years ago

Watch the video that I shared to know it to produce this error. Yes, I tired it on a fresh WordPress install with all the default settings.

Plus, the video that I made wasn't from a small screen laptop.

#7 follow-up: @knutsp
7 years ago

Firefox and IE9:
With "Expand the editor ..." on, type a very long word until the horizontal scrollbar appears. Turn off "Expand the editor ...". The visible scrollbar is still there but the usable textarea is now just just a portion of the width of full area.

Chrome:
The word gets wrapped (!) long before I manage to write a word that is long enough to toggle the scrollbar, with or without "Expand the editor ..."

#8 in reply to: ↑ 7 @hardeepasrani
7 years ago

Replying to knutsp:

Chrome:
The word gets wrapped (!) long before I manage to write a word that is long enough to toggle the scrollbar, with or without "Expand the editor ..."

Yup, Chrome is working fine with the new editor.

#9 follow-up: @azaozz
7 years ago

  • Keywords close added; needs-patch removed

We probably can set word-wrap: break-word on the editor body so FF and newer IE behave like Chrome, however thinking this is an "error condition" the user should be able to see and correct.

The position of the horizontal scrollbar depends on the iframe body height which is different in different browsers when there are only 1-2 lines of text in the editor.

Last edited 7 years ago by azaozz (previous) (diff)

#10 in reply to: ↑ 9 ; follow-up: @knutsp
7 years ago

Replying to azaozz:

We probably can set word-wrap: break-word on the editor body so FF and newer IE behave like Chrome, however thinking this is an "error condition" the user should be able to see and correct.

All browsers wraps lines in the middle of the edit area ij the visual editor. I would like to use the whole width for my text. However, this is the same behaviour as in 3.9.2.

#11 in reply to: ↑ 10 ; follow-up: @azaozz
7 years ago

Replying to knutsp:

This is actually a feature. The editor iframe body is set to the theme's width, so text is wrapped at the same length as on the front-end. This is usually set in editor-style.css in the theme.

#12 in reply to: ↑ 11 @knutsp
7 years ago

Replying to azaozz:

This is actually a feature.

Ahh! Should have guessed. Very ok. I usually go with the text editor, anyway.

Would like to add: Keep up the very, very good work, azaozz.

#13 @azaozz
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks @knutsp :)

Closing this as wontfix, as this is expected behavior. A horizontal scrollbar is very bad UX, but we shouldn't prevent it in the editor as it would probably appear on the front-end too. It's better if the users are aware and fix the text that causes it.

Note: See TracTickets for help on using tickets.