WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 weeks ago

Last modified 2 weeks ago

#29238 closed defect (bug) (duplicate)

Parsing error for the month of September in wp-includes/SimplePie/Parse/Date.php

Reported by: softmodeling Owned by: rmccue
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: External Libraries Keywords: has-patch
Focuses: Cc:
PR Number:

Description

September was assigned a 8 instead of a 9 in one of the name variations for the month

Attachments (1)

29238.patch (393 bytes) - added by softmodeling 5 years ago.

Download all attachments as: .zip

Change History (10)

@softmodeling
5 years ago

#1 @ocean90
5 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to Future Release

Can you please report this issue upstream too? See https://github.com/simplepie/simplepie.

#2 @SergeyBiryukov
5 years ago

  • Component changed from Feeds to External Libraries

#3 @softmodeling
5 years ago

Submitted the pull request with the change to https://github.com/simplepie/simplepie.

#4 @SergeyBiryukov
5 years ago

  • Version changed from trunk to 2.8

Introduced in [10666].

#5 @chriscct7
4 years ago

The pr was submitted as https://github.com/simplepie/simplepie/pull/374. It has not been merged.

@rmccue can you take a look at this?

#6 @SergeyBiryukov
4 years ago

  • Owner set to rmccue
  • Status changed from new to assigned

#7 @trepmal
11 months ago

Just noting this was fixed upstream several years ago in version 1.4. Updating SimplePie also discussed in #36669

#8 @Hareesh Pillai
3 weeks ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

Thanks for this ticket @softmodeling!

As @trepmal noted above, this has been fixed upstream. Because the library needs to be updated for the fix to be included, I'm going to mark this as a duplicate of #36669, where the update of the library is being tracked.

#9 @desrosj
2 weeks ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.