WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#2926 closed defect (bug) (fixed)

Theme files are not ordered alphabetically

Reported by: Arrrr Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.0.3
Component: Administration Keywords: theme theme-editor order alphabetical has-patch
Focuses: Cc:

Description

When editing themes, files are not listed alphabetically in the theme files sidebar.

Attachments (2)

r3979_theme-editor.patch (1.1 KB) - added by Arrrr 8 years ago.
2926.diff (470 bytes) - added by Arrrr 8 years ago.
Adds ksort() to page_template_dropdown() so that the templates are sorted there as well.

Download all attachments as: .zip

Change History (10)

Arrrr8 years ago

comment:1 darkfate8 years ago

Does it really need to be in alphabetical order?

comment:2 Arrrr8 years ago

For large-scale sites with many template files, yes. Ever tried managing a 4,000 page WordPress site that has a different layout for each of 3 sections?

The small usability bump that alphabetical order provides when digging thru a list of 25 to 30 files can make the process much less aggrevating.

Arrrr8 years ago

Adds ksort() to page_template_dropdown() so that the templates are sorted there as well.

comment:3 foolswisdom8 years ago

  • Keywords theme theme-editor order alphabetical has-patch added; themes removed
  • Milestone set to 2.1
  • Type changed from enhancement to defect

comment:4 foolswisdom8 years ago

Ticket #3011 is basically a duplicate of this.

comment:5 matt7 years ago

  • Milestone changed from 2.1 to 2.2

comment:6 foolswisdom7 years ago

  • Milestone changed from 2.2 to 2.3

comment:7 rob1n7 years ago

(In [5380]) Sort page templates by name. Props Arrrr. see #2926

comment:8 ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.