WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#29268 closed defect (bug) (fixed)

Pasting non-oembed urls has unexpected behaviors

Reported by: Ipstenu Owned by: azaozz
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords: has-patch
Focuses: Cc:

Description

In visual editor only.

1) Pasting a non-oembed URL on it's own causes an embed to 'flash' before putting in the URL. However it ALSO returns your cursor to the top of the page, which is really bad for accessibility

2) If you paste in multiple non-oembeds, one of them will eventually get stuck: https://cloudup.com/cJr27fOB96i

3) If you tab between visual and text enough times (twice in my checks), you'll get stuck with ALL non-oembeds acting like this: https://cloudup.com/cZJJ3gv2Cbp

The URL I was pasting in was https://wordpress.org/support/topic/40-beta-4-oembed-behavior-with-multiple-non-oembed-urls?replies=1&view=all (which is also where this was initially reported)

Tested on TwentyFourteen with no plugins active.

Attachments (1)

29268.patch (679 bytes) - added by iseulde 7 years ago.

Download all attachments as: .zip

Change History (7)

#1 @tellyworth
7 years ago

  • Milestone changed from Awaiting Review to 4.0

I can't reproduce 2, but 3 happens for me in FF 31.0.

#2 @Ipstenu
7 years ago

2 happened after 3 links, and not before, on Chromium 36.0.1985.125 (0) on Mac

#3 @obrienp
7 years ago

I initially reported this one. I forgot to say that I'm using Chrome 36.0.1985.143 (Official Build 287914) m on Windows 7 64 bit. Not sure if that matters, but hopefully it helps.

@iseulde
7 years ago

#4 @iseulde
7 years ago

  • Component changed from Editor to TinyMCE
  • Keywords has-patch added

That should fix it. We shouldn't replace the urls with a loading placeholder in the first place, but it's a bit late now to try other things. I'll open another ticket for that for the next cycle.

#5 @azaozz
7 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 29571:

TinyMCE wpView: prevent errors when pasting multiple non-embeddable URLs, props avryl, fixes #29268

#6 @azaozz
7 years ago

In 29577:

TinyMCE wpView: fix showing errors for non-embeddable URLs, no-ssl or no items. Props avryl, fixes #29114, see #29268.

Note: See TracTickets for help on using tickets.