WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29287 closed defect (bug) (duplicate)

Single apostrophe converted to left quote incorrectly when text bolded

Reported by: awhig Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.2
Component: Formatting Keywords:
Focuses: Cc:
PR Number:

Description

In the string

Cook's

if Cook is bolded, and not the apostrophe and the s, then the apostrophe is converted to a left quote, instead of a right quote.

A clearer example of how this is used is below.

Australian fashion editor Christine Centenera's street style is always on point.

I imagine this will happen for any formatting of the string where it occurs right before the apostrophe s.

Steps to reproduce:

  1. In a new post, in visual editor, type the word "Cook's"
  2. Highlight the string "Cook" and bold it, using the tool.
  3. Preview the post

Rich

Change History (2)

#1 @miqrogroove
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18549.

#2 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.