WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29295 closed defect (bug) (duplicate)

My Sites Menu and Profile Menu Should Scroll

Reported by: mrjarbenne Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Toolbar Keywords:
Focuses: ui, administration, multisite Cc:
PR Number:

Description

In a Multisite installation, the My Sites menu (when a user has a larger number of sites) can extend past the bottom of the browser on smaller screens (phone, tablet, etc.) Scrolling advances the page behind the menu, instead of allowing vertical navigation of the options within that menu. The same issue occurs on the right hand side when the Profile menu is populated with additional links: this occurs particularily when BuddyPress is active.

This video displays the issue more clearly: http://www.screencast.com/t/siMIp5PJDDL

Change History (3)

#1 @helen
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from trunk to 3.2

Duplicate of #15317.

#2 @mrjarbenne
5 years ago

Thanks @helen for taking a look at this. I don't believe that #15317 is a duplicate of this issue. The conversation there seems to be focused on limiting the number of items that might appear in a menu. That logic is bound to fail, given that the number would need to account for the smallest possible screen a user might use to navigate their site. A better fix would be to enable scrolling of all of the dropdowns, in the same way that the dashboard menu allows scrolling, when/if a menu extends beyond the bottom of the browser. This functionality can also be seen on wordpress.org: when the menu reverts to a "hamburger" flyout on smaller screens, the resulting menu scrolls beyond the boundaries of the screen size.

If indeed the conversation eventually comes around to focusing on the issue I'm highlighting here, certainly the ticket title and initial report isn't useful in bringing attention to this issue, which seems to have sat dormant for two years up until a search plugin is mentioned, which is great functionality when we are talking about a menu with a high number of items, but is overkill when a menu is exceeding the screen size by only two or three lines.

#3 @mrjarbenne
5 years ago

Upon further reading and exploration of the patches, that ticket does eventually come around to addressing the issue. I'll re-direct my comments to that ticket.

Cheers.

Note: See TracTickets for help on using tickets.