Make WordPress Core

Opened 10 years ago

Closed 4 months ago

#29297 closed defect (bug) (wontfix)

Inconsistency for language dropdown and updates

Reported by: pavelevap's profile pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: I18N Keywords: needs-patch
Focuses: Cc:

Description

I tried to test another language and copied de_DE.mo file into wp-content/languages.

1) In Settings - General I can see de_DE version now and that is right. But when I try to use only admin-de_DE.mo file, then de_DE is not there. I am not sure if it is a feature or bug. But maybe we should check all files (subprojects)?

2) Anyway, when there are both de_DE.mo and admin-de_DE.mo, language is available in dropdown, but language updates does not work for de_DE. It is probably for checking .po files by API. But is is not consistent, because users can see that they can switch to de_DE language and updates will not work.

Change History (7)

#1 @pavelevap
10 years ago

I am using cs_CZ as default.

This ticket was mentioned in IRC in #wordpress-dev by helen. View the logs.


10 years ago

#3 @ocean90
10 years ago

  • Milestone changed from Awaiting Review to Future Release
  • Version changed from trunk to 3.0

get_available_languages() was introduced in 3.0. It's something we can improve in 4.1.

And yes, .po files are required.

#4 @ocean90
10 years ago

Related: #29892

#5 @chriscct7
9 years ago

  • Keywords needs-patch added

This ticket was mentioned in Slack in #core-i18n by ocean90. View the logs.


8 years ago

#7 @swissspidy
4 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

This is working as intended and by design. The existence of de_DE.mo is checked and the .po is required for reading the headers so we can see when the file was last updated.
I don't see a reason for changing this.

With the new translation system in 6.5 it will be possible to just use .l10n.php for translations, see #60554. That will reduce confusion hopefully.

Note: See TracTickets for help on using tickets.