WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#29298 closed enhancement (duplicate)

press-this.php, new class for extern URL wrapper

Reported by: Stagger Lee Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.2
Component: Press This Keywords: has-patch
Focuses: Cc:

Description

Please give us one new class inside paragraph wrapping extern URL (linkable Title) in Press this posts ?

Easy to do it manually, but it is a core file. If we want to style link as button "via" and dot "." are outside because paragraph doesnt have a class.

Or some function.php override, if anyone know. Searched for one day and could not find it.

Not to much to ask i believe. Tried new press this plugin (alpha) but it is impossible to chose category in popup window, for now. Could not find it.

$content .= '<p>';
$content .= '<p class="some-new-class">';

Attachments (2)

29298.diff (385 bytes) - added by kraftbj 5 years ago.
Adds wppt-source class
29298.2.diff (385 bytes) - added by kraftbj 5 years ago.
use wppt_source to match the system in the feature plugin

Download all attachments as: .zip

Change History (6)

#1 @Stagger Lee
6 years ago

Sorry forgot, it is line 641 in press-this.php.

#2 @kraftbj
5 years ago

  • Keywords has-patch added

Regarding the lack of category option in the Featured Plugin, I opened an issue at https://github.com/MichaelArestad/Press-This/issues/12

Attaching a patch to add wppt_source class, though your thoughts on the featured plugin are much appreciated since dev efforts toward Press This will take place there.

Last edited 5 years ago by kraftbj (previous) (diff)

@kraftbj
5 years ago

Adds wppt-source class

@kraftbj
5 years ago

use wppt_source to match the system in the feature plugin

#3 @kraftbj
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16922.

Looking through older tickets, this is actually a duplicate.

#4 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Type changed from feature request to enhancement
Note: See TracTickets for help on using tickets.