Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#29328 closed defect (bug) (worksforme)

impossible to paste with keyboard shortcuts on Firefox

Reported by: djibs13's profile Djibs13 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Hello,

I use the latest version of Firefox on Mac.

Since wordpress 3.9 (or 3.9.1 I do not know), it is imposible to paste text with keyboard shortcuts (cmd + v). The problem is present only for the visual portion of the text editor.

The problem is still present in Wordpress 4.0 Beta 4.

No problem with Chrome or Safari.

The copy / paste with the right mouse button works fine

Attachments (1)

paste firefox.mp4 (1.1 MB) - added by Djibs13 10 years ago.
Paste in firefox

Download all attachments as: .zip

Change History (9)

@Djibs13
10 years ago

Paste in firefox

#1 @SergeyBiryukov
10 years ago

Could not reproduce with Firefox 31 on Windows.

#2 @ocean90
10 years ago

  • Keywords reporter-feedback added
  • Version changed from trunk to 3.9

Works for me too in 3.9 and current trunk with Firefox 31 on OSX.

Please disable all plugins, activate one of the default themes and try it again.

#3 @azaozz
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Works for me too in 4.1-beta1. May have been caused by a Firefox addon? Feel free to reopen with steps to consistently reproduce.

#4 @Djibs13
9 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I tried disabling all firefox plugins and addon but I still have the problem.
My friend also has the problem.

I use firefox on OS X.

Last edited 9 years ago by Djibs13 (previous) (diff)

#5 @azaozz
9 years ago

Could you provide some more info:

  • Does it work when pasting in the Text editor?
  • Does it work when pasting in other textareas?
  • Does it work in the TinyMCE demo? http://www.tinymce.com/tryit/basic.php
  • Does it work if you change your keyboard layout/language?

#6 @Djibs13
9 years ago

  • Does it work when pasting in the Text editor? The problem is present only for the visual portion of the text editor.
  • Does it work when pasting in other textareas? Yes (for example in this textarea it works)
  • Does it work in the TinyMCE demo? No
  • Does it work if you change your keyboard layout/language? No

#7 @SergeyBiryukov
9 years ago

  • Keywords reporter-feedback removed
  • Milestone set to Awaiting Review

#8 @iseulde
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Is this still a problem? I cannot reproduce this problem either and 3 other people can't.
Does this happen here: http://html5demos.com/contenteditable? If yes, it must be something related to your browser.
If it doesn't happen there and it does happen in the TinyMCE demo, then you should report it to TinyMCE also.

Note: See TracTickets for help on using tickets.