Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#29345 closed defect (bug) (duplicate)

Space is deleted between rows when updating a post

Reported by: moshe1010's profile Moshe1010 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description (last modified by ocean90)

  1. Copy/Paste the following to the html editor:
<table style="background-color: #f9f9f9; border: 1px solid #aaaaaa; padding: 5px; width: 300px;" border="0">
<tbody>
<tr>
<td style="border: 0px;"><strong>I. מבוא ומושגים כללים</strong>
<span style="color: #ffffff;">**</span><a href="#a1">1. סוגי אצנים</a>
<span style="color: #ffffff;">**</span><a href="#a2">2. קילומטראז</a>
<span style="color: #ffffff;">**</span><a href="#a3">3. אורך הצעד וקצב הצעד</a>
<span style="color: #ffffff;">**</span><a href="#a4">4. אימון קילומטראז'/ אימון בסיס/ אימון נפח</a>
<span style="color: #ffffff;">**</span><a href="#a5">5. אימון עליות</a>
<span style="color: #ffffff;">**</span><a href="#a6">6. אימון אינטרוולים</a>
<span style="color: #ffffff;">**</span><a href="#a7">7. דופק, דופק מקסימלי ואחוז מהדופק המקסימלי:</a>
<span style="color: #ffffff;">**</span><a href="#a8">8. קצב</a>
<span style="color: #ffffff;">**</span><a href="#a9">9. סוגי ריצה (איטית, קלה, חזקה, מהירה)</a><strong>II. עקרונות אימון</strong>
<span style="color: #ffffff;">**</span><a href="#b1">1. הקדמה</a>
<span style="color: #ffffff;">**</span><a href="#b2">2. מערכת עצבית</a>
<span style="color: #ffffff;">**</span><a href="#b3">3. חשיבות ההבדל בין אימון למבחן</a>
<span style="color: #ffffff;">**</span><a href="#b4">4. אימוני איכות – מתי ואיך?</a>
<span style="color: #ffffff;">**</span><a href="#b5">5. אימונים לפי תקופות</a>
<span style="color: #ffffff;">**</span><a href="#b6">6. מדוע זה כל כך קשה לי?</a>
<span style="color: #ffffff;">**</span><a href="#b7">7. כללי אצבע</a>
<span style="color: #ffffff;">**</span><a href="#b8">8. אימוני כוח</a>
<span style="color: #ffffff;">**</span><a href="#b9">9. טכניקה</a>
<span style="color: #ffffff;">**</span><a href="#b10">10. טייפר</a>
<span style="color: #ffffff;">**</span><a href="#b11">11. גמישות ויציבה</a>
<span style="color: #ffffff;">**</span><a href="#b12">12. התאוששות, אימון יתר וקשקוש ימי המנוחה</a>
<span style="color: #ffffff;">**</span><a href="#b13">13. בניית תוכנית אימונים – ועמידה בה</a>

<strong>III. צבא</strong>
<span style="color: #ffffff;">**</span><a href="#c1">1. כיצד עובד האימון הגופני בצבא?</a>
<span style="color: #ffffff;">**</span><a href="#c2">2. מדוע זה מתנהל ככה?</a>
<span style="color: #ffffff;">**</span><a href="#c3">3. היכולות הגופניות בסיירות והיחידות המובחרות</a>
<span style="color: #ffffff;">**</span><a href="#c4">4. מה נדרש מכם בגיבושים?</a>
<span style="color: #ffffff;">**</span><a href="#c5">5. כיצד להתאמן לגיבושים?</a>
<span style="color: #ffffff;">**</span><a href="#c6">6. איך להיות חזק בגיבושים?</a>
<span style="color: #ffffff;">**</span><a href="#c7">7. תזונה</a>
<span style="color: #ffffff;">****</span><a href="#c7a">א. הנחיות כלליות</a>
<span style="color: #ffffff;">****</span><a href="#c7b">ב. יום לפני אימון</a>
<span style="color: #ffffff;">****</span><a href="#c7c">ג. בזמן המבחן</a>
<span style="color: #ffffff;">****</span><a href="#c7d">ד. לאחר המבחן</a>
<span style="color: #ffffff;">**</span><a href="#c8">8. כיצד לנהוג ביום המבחן?</a>
<span style="color: #ffffff;">**</span><a href="#c9">9. תוצאות</a></td>
</tr>
</tbody>
</table>
  1. Correct the spacing between the alpha numerals with Shift + Enter

3, Press to update the post.

  1. Press to update the post again
  1. And again

Chrome 36, OS X and Windows 8.1 Occurs in WP 3.9.2 and WP 4 B4

See the following for more details:
http://imageshack.com/a/img539/8885/pVqTQR.gif

Change History (3)

#1 @ocean90
10 years ago

  • Description modified (diff)

#2 @azaozz
10 years ago

This is a known problem in autop. It doesn't fully support <p> inside of <td>. A workaround is to wrap the paragraphs in a <div> (so it becomes <td><div>text with paragraphs...</div></td>).

Last edited 10 years ago by azaozz (previous) (diff)

#3 @SergeyBiryukov
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20943.

Note: See TracTickets for help on using tickets.