WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#29365 closed defect (bug) (invalid)

Bulk actions on custom posts type automatically delete metadata

Reported by: vitolioce Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version: 3.9.2
Component: Posts, Post Types Keywords: reporter-feedback
Focuses: Cc:

Description

Hello,
I would to point out a bug that I found on one of my sites made with WordPress.
The site in question is www.weekendinliguria.it, based on WordPress, in which I have included two types of custom posts type (CPT) to which I have assigned some special data as metadata.
As my client pointed out, I noticed that the metadata assigned to the CPT are automatically deleted. Eliminated the human cause, and any poorly written code by me, I found that when I go to a group action on CPT metadata are regularly cleared for all CPT of that type. The construction of the CPT was made according to the rules explained by the relevant article in the WordPress Codex. I also noticed that this problem does not occur on group actions of articles and pages.
I hope to be useful in reporting this bug, and I remain at your disposal to correct it as soon as possible.

Change History (7)

#1 follow-up: @SergeyBiryukov
6 years ago

  • Component changed from Administration to Posts, Post Types
  • Keywords reporter-feedback added
  1. What do you mean by action groups?
  2. Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

#2 @azaozz
6 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 29770:

Fix tapping on the menu in iOS and Android, fixes #29365 for trunk

#3 @azaozz
6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Ops, closed the wrong ticket, sry.

Version 0, edited 6 years ago by azaozz (next)

#4 in reply to: ↑ 1 @vitolioce
6 years ago

Replying to SergeyBiryukov:

  1. What do you mean by action groups?
  2. Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

1: I mean group actions (or bulk actions) in the post section.
2: Yes, I have disabled every plugin and set a default theme

#5 @helen
6 years ago

I can't reproduce. Could you provide the steps you're using to add metadata and quick edit, and if there is any code involved in adding/saving fields, provide that as well?

#6 @SergeyBiryukov
6 years ago

  • Summary changed from Action groups on custom posts type automatically delete metadata to Bulk actions on custom posts type automatically delete metadata

#7 @wonderboymusic
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

No reporter feedback in 7 months, not reproducible

Note: See TracTickets for help on using tickets.