WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29426 closed defect (bug) (duplicate)

get_attachment_link() does not return pretty URL for attachments uploaded directly via Media (e.g. not added through post editing)

Reported by: keketovic Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.2
Component: Media Keywords:
Focuses: Cc:

Description

pretty URLs fully set up, enabled and working, exacept for this:

returned URL: http://[redacted].com/?attachment_id=63

expected URL would be e.g.: http://[redacted].com/attachment/63

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1914.

Note: See TracTickets for help on using tickets.