Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#29434 closed defect (bug) (worksforme)

TinyMCE: Single Return List to List Items

Reported by: rickalee's profile rickalee Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords: close reporter-feedback
Focuses: Cc:

Description

Single return lines now only get wrapped in one list item instead of making bulleted list.

Attachments (1)

tinymce_bullets.jpg (91.6 KB) - added by rickalee 10 years ago.

Download all attachments as: .zip

Change History (14)

#1 @helen
10 years ago

  • Version trunk deleted

I believe this is how it's always worked, or at least how TinyMCE has worked for as long as I've used it - single line breaks within a list item are valid.

#2 @rickalee
10 years ago

Previously in TinyMCE it added separate bullets to all lines instead of wrapping in one list item.

#3 @helen
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I just tested in 3.9.2 as well as 4.0 trunk and got what I described and expected - all lines created with line breaks became one bullet item. Separate paragraph items became separate bullets. Not sure what version or set up you were experiencing different behavior in, but this isn't a bug.

#4 follow-up: @rickalee
10 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version set to trunk

In 3.9.2 with no plugins active - bulleted and numbered wraps each line in individual list items
http://g.recordit.co/LaCXphfATC.gif

Trunk with no plugins active - bulleted and numbered wraps all lines in one list item.
http://g.recordit.co/EhXTWiBOVA.gif

#5 in reply to: ↑ 4 @knutsp
10 years ago

  • Keywords close added

Replying to rickalee:

In 3.9.2 with no plugins active - bulleted and numbered wraps each line in individual list items

Not here. All tests made both with Firefox 31 and again with Chrome 36, on Windows.

Test 1: I make three lines in a text editor using a single Enter in between, copy them and paste into the visual editor, running WP 3.9.2. Then I mark the lines and hit the bullet list button. Result: One bullet item containing the three lines.

Test 2: I make three lines in the visual editor running WP 3.9.2 by pressing shift+Enter between the lines. Mark them and hit bullet button. Result: One bullet, as above.

Test 3: I make three lines in the visual editor by pressing a normal Enter between them (paragraphs created), mark them and hit the bullet button. Result: Three bullet items.

Same tests on WP 4.0-RC1, Firefox and Chrome: Exact same results. As far as I can recall this has also been the case in WP 3.8 and earlier.

#6 @Kelderic
10 years ago

I've confirmed all of knutsp's tests. The difference here seems to be in whether the new line is created in the text editor or in the visual editor.

#7 @knutsp
10 years ago

  • Keywords reporter-feedback added

My "Test 1" was not involving the text editor in WordPress, but an external one.

New test:

In the text editor of WordPress, enter three lines using the Enter key (once). Switch to the visual editor of WordPress. Mark the lines. Press the bullet (unordered) list button.

4.0-RC1: One bullet
3.9.2: One bullet

#8 follow-up: @rickalee
10 years ago

See Kelderic's comment. I commonly paste Word or Pages documents into Text Mode to clear formatting and then toggle to Visual to add bullets and headings.

The expected output of wrapping each line individually in list items has changed.

#9 in reply to: ↑ 8 @knutsp
10 years ago

Replying to rickalee:

See Kelderic's comment. I commonly paste Word or Pages documents into Text Mode to clear formatting and then toggle to Visual to add bullets and headings.

The expected output of wrapping each line individually in list items has changed.

Not changed for me in any way.

#10 @azaozz
10 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Agree with @helen and @knutsp. Works as expected here too. Note that if you select a list and click the button again, each list item is converted back to a paragraph. Re-closing as worksforme. If the behavior is different in some edge cases, please open a ticket on TinyMCE's trac: http://www.tinymce.com/develop/bugtracker.php.

#11 @SergeyBiryukov
10 years ago

#29584 was marked as a duplicate.

#12 @ocean90
10 years ago

#30801 was marked as a duplicate.

#13 @iseulde
9 years ago

#30801 was marked as a duplicate.

Note: See TracTickets for help on using tickets.