WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#29439 closed enhancement (maybelater)

add a filter for add plugin compatible with my WP version

Reported by: Kniebremser Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Plugins Keywords:
Focuses: Cc:

Description

Add a filter for all the tabs so I just plugins are displayed that are compatible with my WP version according Plugin Author.

Change History (3)

#2 @Kniebremser
5 years ago

Hi,

Please do not get me wrong.
The new look I find top. I am bothered only the displayed plugins.
Under the tabs "Featured" and "Popular" I see plugins with many downloads and good ratings.

For example:
Tumblr Importer
Last Updated: 1 year
Untested with your version of WordPress

How can I recommend a plugin where I do not know if it works with WP 4.0?
The development of WordPress continues. Does the plugin works with my WP version.
A newbie or a user without php knowledge might thereby destroying its WP installation and stands on lost positions.

My idea is a checkbox for "Featured", "Popular" and "Search", where enabled by default "Show only plugins that are compatible with my WP version". The user must own the checkbox to disable to see outdated and untested plugins.

#3 @DrewAPicture
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Hasn't been a great deal of interest in this capability as yet. You can currently accomplish this by modifying the return object on the plugins_api hook.

Closing as maybelater.

Note: See TracTickets for help on using tickets.