WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#29473 closed defect (bug) (fixed)

oEmbed previews from "Insert from URL" tab have stopped working

Reported by: johnbillion Owned by: nacin
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: Embeds Keywords: has-patch commit
Focuses: javascript, administration Cc:

Description

Previously: #28195

Pasting an oEmbed-supporting URL into the "Embed from URL" tab in the media manager is supposed to give us a preview. This was working at some point (see #28820) but appears to have stopped working.

Marking as 4.0 for investigation, even though it's getting tight.

Attachments (2)

29473.diff (608 bytes) - added by johnbillion 6 years ago.
29473.patch (495 bytes) - added by azaozz 6 years ago.

Download all attachments as: .zip

Change History (9)

#1 @johnbillion
6 years ago

  • Keywords needs-testing removed

The issue is that the html parameter passed to media.view.EmbedLink.renderoEmbed is an object, not a string.

Caused by r29615.

@johnbillion
6 years ago

#2 @johnbillion
6 years ago

  • Keywords needs-patch dev-feedback added

Patch. Marking as dev-feedback as we're in RC.

This ticket was mentioned in IRC in #wordpress-dev by johnbillion. View the logs.


6 years ago

#4 @azaozz
6 years ago

Patch looks good. Thinking it needs to check whether response.body exists, so we don't end up with "undefined" in there. Something like:

var html = ( response && response.body ) || '';
this.$('.embed-container').show().find('.embed-preview').html( html );

@azaozz
6 years ago

#5 @azaozz
6 years ago

29473.patch adds check whether response.body exists to 29473.diff.

#6 @helen
6 years ago

  • Keywords has-patch commit added; needs-patch dev-feedback removed

#7 @nacin
6 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 29680:

Media Modal: Fix 'Insert from URL' oEmbed previews.

props johnbillion, azaozz.
fixes #29473.

Note: See TracTickets for help on using tickets.