Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#29481 closed defect (bug) (duplicate)

Cannot manually enter page number when browsing the Plugins -> Add New screens

Reported by: johnbillion's profile johnbillion Owned by:
Milestone: Priority: low
Severity: minor Version: 3.1
Component: Plugins Keywords: has-patch
Focuses: administration Cc:

Description

Steps to reproduce:

  1. Go to Plugins -> Add New and switch to the Popular tab.
  2. Enter a page number in the text input between the pagination controls, then hit enter.
  3. Note that nothing happens.

This behaviour works as expected on other screens where pagination controls are present.

This crippling bug has been present since 3.1.

Attachments (1)

29481.diff (2.0 KB) - added by jesin 10 years ago.

Download all attachments as: .zip

Change History (5)

@jesin
10 years ago

#1 @jesin
10 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

Patch 29481.diff does the following:

  • Adds a <form> tag enclosing the list of plugins and top navigation.
  • Adds a nonce field to the WP_Plugin_Install_List_Table::display_tablenav() function.
  • Checks for HTTP request variable _wp_http_referer and adds the query arg paged to the URL.

#2 @karpstrucking
10 years ago

this is a duplicate of #18724 but I'm not sure the protocol for closing duplicates - #18724 has been around for awhile, but your patch is more thorough than the latest patch there.

#3 @jesin
10 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18724.

#4 @ocean90
10 years ago

  • Keywords good-first-bug needs-testing removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.