WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#29506 closed defect (bug) (worksforme)

Incomplete admin translations

Reported by: digipro Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: I18N Keywords: close
Focuses: Cc:

Description

After updating from 4.0 RC2 to RC3 it the language package is not translating the admin panel correctly.

Instead of Swedish text, some text still in english in RC3, but in Swedish in RC2!

Best regards
Bengt Jönsson
Sweden

Change History (7)

#1 @SergeyBiryukov
6 years ago

  • Component changed from General to I18N
  • Version set to trunk

#2 @johnbillion
6 years ago

  • Milestone changed from Awaiting Review to 4.0
  • Summary changed from WP 4.0 RC3 to Incomplete admin translations

Confirmed. The Swedish translation is marked as 100% complete, so there shouldn't be any English text showing, but there is.

Example:

https://i.imgur.com/fNGJE22.png

#3 @SergeyBiryukov
6 years ago

admin-sv_SE.po and admin-sv_SE.mo are downloaded correctly, but sv_SE.po and sv_SE.mo are empty (only contain the header). Manual export from GlotPress works fine though.

#4 @netweb
6 years ago

  • Keywords dev-feedback added

http://irclogs.wordpress.org/chanlog.php?channel=wordpress-dev&day=2014-09-03&sort=asc#m917118

> XavierB: i18n/packaging bugs?
> nacin: yeah
> nacin: there are some line ending issues our current pomo libraries don't account for

Maybe Related #29480

Edit: Ignore the above, there are no "new line" warnings for Sweedish admin or network admin translations.

Last edited 6 years ago by netweb (previous) (diff)

#5 @netweb
6 years ago

  • Keywords dev-feedback removed

My bad, didn't mean to add keyword.

#6 @ocean90
6 years ago

  • Keywords close added

Asked Sergey to which download he was referring and it was http://downloads.wordpress.org/translation/core/4.0-RC2/sv_SE.zip. In the meantime a new package was build (probably because of the Release Lead string) and Sergey and I can't reproduce comment:3 anymore. All strings are translated: https://cloudup.com/cLuKPucAlay.

#7 @nacin
6 years ago

  • Milestone 4.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

In short: The script hosed some language packs, but they pretty quickly got rebuilt. I've confirmed none are affected at this point, and I'll add in some sanity checks to confirm it can't happen again.

https://glotpress.trac.wordpress.org/ticket/352 is running on the server from which these are being generated. It just isn't committed yet as it's lacking unit tests.

Note: See TracTickets for help on using tickets.