Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#29517 closed defect (bug) (worksforme)

wp 4.0 - Internal/500 error on JetPack wpvideo shortcode

Reported by: helloari's profile helloari Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Shortcodes Keywords:
Focuses: Cc:

Description

i have a WP.org 3.9.2 site with jetpack (with "Shortcode Embeds" enabled)
i wrote a post (about wp 4.0) using the [wpvideo bUdzKMro] shortcode for the intro video. the video showed up fine on the live post BUT then when i updated to wp 4.0 my post would not load - i got a 500 error. i could edit it but not view it. when i removed the shortcode the 500 error went away. i embedded with html embed code and the video showed up fine.

specifically the error is: "Internal Server Error"

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@… and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

my theme is old and i did some plugin updates before i did the wp 4 update.

ok, now i did another test and i confirmed that when i turned off the "Shortcode Embeds" feature the post loaded fine. of course the shortcode was not rendered but it didn't break the entire page.

so this is both a wp 4.0 bug and a jetpack bug.

note that this bug ticket tool is not letting me select "4" as the version so i'm selecting "trunk"

Change History (2)

#1 @macmanx
10 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I'm unable to reproduce the issue: http://macmanx.com/2014/09/04/wordpress-4-0-released/

Have you contacted the Jetpack folks? http://jetpack.me/contact-support/

#2 @SergeyBiryukov
10 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.