WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#29521 closed defect (bug) (duplicate)

SVG upload via theme customizer

Reported by: jimmy.smutek Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Customize Keywords:
Focuses: administration Cc:

Description (last modified by SergeyBiryukov)

I'm building a theme and thought it would be nice to allow the option to use an svg for a logo. I added svg to the allowed mime types and am able to upload svg via the media library, but not via the theme customizer.

When trying to upload an svg via the media uploader the file is grayed out, and non selectable. (see screen shot)

I did skim ticket 22149 (Customizer Uploader doesn't restrict by file type) but It seems that svg is a media type that should be allowed in the theme customizer.

Sorry if this doesn't belong here - I brought this up at my local WordPress meet up last week and it was suggested that I submit a ticket here.

Attachments (1)

screen.jpg (114.6 KB) - added by jimmy.smutek 3 years ago.
screen shot

Download all attachments as: .zip

Change History (4)

@jimmy.smutek
3 years ago

screen shot

#1 @SergeyBiryukov
3 years ago

  • Description modified (diff)

#2 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24251.

#3 @jimmy.smutek
3 years ago

thank you.

Last edited 3 years ago by jimmy.smutek (previous) (diff)
Note: See TracTickets for help on using tickets.